PowerSchool SIS Performance
Incident Report for PowerSchool Products
Resolved
We are no longer experiencing any widespread degraded performance with PowerSchool SIS, and all systems are working as expected.
Our team are continuing to monitoring the system performance.
If you are still experiencing degraded performance, please reach out to PowerSchool Support.
Posted Mar 19, 2024 - 08:46 PDT
Update
We are no longer experiencing any widespread degraded performance with PowerSchool SIS, and all systems are working as expected.
Our team are continuing to monitoring the system performance, and we will keep you posted on the resolution and more details as they become available.
If you are still experiencing degraded performance, please reach out to PowerSchool Support.
Posted Mar 05, 2024 - 06:37 PST
Monitoring
We are aware of degraded performance with PowerSchool SIS. We are monitoring the situation and will provide you with regular updates as they become available. We appreciate your patience while we work to resolve this issue.
Posted Mar 04, 2024 - 07:23 PST
This incident affected: PowerSchool SIS.