Unified Classroom - Intermittent Loading
Incident Report for PowerSchool Products
Resolved
This incident has been resolved.
Posted Dec 01, 2021 - 11:45 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 01, 2021 - 10:21 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 01, 2021 - 09:43 PST
Investigating
Some users are experiencing degraded service while using Unified Classroom. Re-loading the page may resolve the issue. We are investigating and will provide further updates.
Posted Dec 01, 2021 - 09:19 PST