Schoology Learning
Incident Report for PowerSchool Products
Resolved
The incident has been resolved. For any residual issues, please contact Schoology Support.
Posted Jun 17, 2021 - 07:37 PDT
Identified
The team has identified the issue and are working to resolve it. Clearing your browser cache should resolve the issue. Thank you for your patience
Posted Jun 17, 2021 - 07:16 PDT
Investigating
Some users may experience issues when navigating to certain courses.

We are investigating and will provide further updates as we have more information. We apologize for the inconvenience.
Posted Jun 17, 2021 - 06:56 PDT
This incident affected: Schoology (Schoology).