Professional Learning / Perform Enterprise blank screen
Incident Report for PowerSchool Products
Resolved
The issue is resolved for any impacted customer that was seeing a blank screen at login or when navigating the site. We apologize for any disruption users experienced for the isolated districts impacted.
Posted Aug 04, 2022 - 12:40 PDT
Identified
We are currently investigating an issue where select customers are experiencing a blank screen upon login. Our engineering team is working on a resolution.
Posted Aug 04, 2022 - 11:52 PDT
This incident affected: Perform Enterprise & Professional Learning.