Naviance Student Access Issues
Incident Report for PowerSchool Products
Resolved
This Incident has been resolved.
Posted Sep 08, 2021 - 13:51 PDT
Monitoring
A fix has been applied, and our development team is continuing to monitor the results.
Posted Sep 08, 2021 - 13:40 PDT
Investigating
We are currently investigating reports of problems logging into Naviance Student.
Posted Sep 08, 2021 - 13:33 PDT
This incident affected: Naviance.