eFP - 19.4 Hosted Customers ONLY
Incident Report for PowerSchool Products
Resolved
The system has been stable for all customers running 19.4 versions of the software.
Posted Aug 02, 2022 - 07:47 PDT
Monitoring
CloudOps has restored the service. All customers should be corrected now.
Posted Aug 01, 2022 - 14:03 PDT
Investigating
We are currently investigating an outage with hosted customers running the 19.4 version of eFinancePlus. We will provide updates to this status page as soon as we have them.
Posted Aug 01, 2022 - 13:47 PDT
This incident affected: eFinancePlus.