PowerSchool Learning and Unified Classroom Class Pages: Uploading Attachments
Incident Report for PowerSchool Products
Resolved
Our team has restored functionality to upload to File Content Blocks within Class Pages for PowerSchool Learning and Unified Classroom. We apologize for any inconvenience this may have caused and appreciate your patience while we worked to resolve these issues. We strive to provide the best possible experience to our customers. Please don’t hesitate to contact PowerSchool Support with any questions.
Posted Apr 22, 2020 - 16:59 PDT
Identified
We have identified the issue and are working on implementing a fix. We apologize for the inconvenience this may have caused and we are working diligently to restore full system functionality. We will provide updates as they become available.
Posted Apr 22, 2020 - 16:43 PDT
Investigating
We are aware that some customers using PowerSchool Learning and Unified Classroom Class Pages may currently be experiencing issues uploading or viewing attachments. We apologize for the inconvenience this may have caused and we are working diligently to restore full system functionality. We will provide updates as they become available.
Posted Apr 22, 2020 - 15:53 PDT
This incident affected: PowerSchool Learning and Unified Classroom.