Performance Matters Login page delays
Incident Report for PowerSchool Products
Resolved
Login issues should now be resolved and accessing pages should load as expected.
Posted Jun 14, 2021 - 04:09 PDT
Investigating
We are currently investigating an issue with accessing and logging into the Performance Matters product.
Posted Jun 14, 2021 - 03:24 PDT
This incident affected: Performance Matters.