PowerSchool SIS maintenance extended and unavailable until 3pm PST
Incident Report for PowerSchool Products
Resolved
All systems are operating as normal.
Posted Sep 11, 2022 - 20:51 PDT
Update
While most customers are operational some accounts are still impacted by the maintenance. Our engineers are aware of the issue and working to get all customers online as soon as possible.

We regret any inconvenience this may have caused.
Posted Sep 11, 2022 - 15:46 PDT
Update
Most all sis instances should be up to date and functioning at this time however we are monitoring the update currently.
Posted Sep 11, 2022 - 15:34 PDT
Update
We are continuing to monitor for any further issues.
Posted Sep 11, 2022 - 10:50 PDT
Monitoring
Product: PowerSchool SIS
Updated maintenance end time: Sunday, September 11, 2022, 3PM PST
Impacted: PowerSchool Hosted Customers Only (Except NC)

Reason for Maintenance: We are performing operating system/security patching on your PowerSchool SIS system. The application will be available for the majority of the window. However, customers will experience intermittent connectivity as the operating system/security patches are applied.

Update: This product will remain under maintenance and be inaccessible until 3pm PST.
We regret any inconvenience this may have caused.
Posted Sep 11, 2022 - 10:11 PDT
This incident affected: PowerSchool SIS.