PowerSchool SIS: Service Disruption impacting Canada Users.
Incident Report for PowerSchool Products
Resolved
We have successfully resolved this issue at this time. We strive to provide the best possible experience for our customers and would like to thank you again for your patience as we worked to resolve this.
Posted Sep 14, 2021 - 11:16 PDT
Monitoring
At this time, we have resolved this issue. While we continue to monitor this issue, if you continue to experience any issues, please reach out to PowerSchool Support via phone, web, or chat through our PowerSchool Community
Posted Sep 14, 2021 - 10:47 PDT
Identified
We have identified the issue and are working to resolve the issue. The team is currently working to address the issue. We apologize for the inconvenience this may have caused. We will continue to provide updates as they become available.
Posted Sep 14, 2021 - 10:11 PDT
This incident affected: PowerSchool SIS.