Professional Learning Canadian Clients Only Site Outage
Incident Report for PowerSchool Products
Resolved
All Canadian Professional Learning sites should now be accessible and the issue is now resolved. Our engineers will continue to monitor for any new issues that arise.
Posted Sep 14, 2021 - 11:01 PDT
Investigating
We are currently investigating an issue with Canadian Professional Learning Customers that may not be able to access the site. This applies to Canadian Customers only and is under investigation.
Posted Sep 14, 2021 - 10:44 PDT
This incident affected: Perform Enterprise & Professional Learning.