Customers experiencing login issues: eFinancePlus is unresponsive, site cannot be reached
Incident Report for PowerSchool Products
Resolved
This incident has been resolved.
Posted May 22, 2023 - 08:08 PDT
Investigating
Engineering is currently investigating this issue. We hope to have an update shortly
Posted May 22, 2023 - 07:11 PDT
This incident affected: eFinancePlus.