PowerSchool SIS Outage For Some Customers
Incident Report for PowerSchool Products
Resolved
We have successfully resolved this issue at this time. We strive to provide the best possible experience for our customers. We want to thank you again for your patience as we worked to resolve this.
Posted Jan 26, 2023 - 13:10 PST
Monitoring
At this time, we have resolved this issue. While we continue to monitor this issue, please reach out to Powerschool Support via phone, web or chat through our Powerschool Community if you continue to experience any issues.
Posted Jan 26, 2023 - 13:09 PST
Investigating
We are aware of a service interruption with the Powerschool SIS product. We are working to assess the situation and will provide you with regular updates as they become available. We appreciate your patience while we work to resolve this issue.
Posted Jan 26, 2023 - 13:08 PST
This incident affected: PowerSchool SIS.