Performance Matters - Delay it saving item edits
Incident Report for PowerSchool Products
Resolved
We have resolved the issue with edits within the platform causing a delay and is back to fully functional.
Posted Jan 20, 2022 - 11:50 PST
Investigating
We have currently identified an issue with a delay when attempting to make edits to items, resources, and tests and attempting to save. Upon saving, the page will spin for 3-4 minutes before completing. We are working on the resolution currently and will update here as soon as more info becomes available.
Posted Jan 20, 2022 - 10:22 PST
This incident affected: Performance Matters.