eSchoolPlus - Partial Service Interruption - Tasks not Processing US West Customers
Incident Report for PowerSchool Products
Resolved
This incident has been resolved.
Posted Dec 07, 2021 - 06:08 PST
Monitoring
A fix has been implemented and we are monitoring the progress.

There are a number of tasks in the queue so the system will take a little time to catch up processing the tasks.
Posted Dec 06, 2021 - 06:48 PST
Update
We are continuing to investigate this issue.
Posted Dec 06, 2021 - 05:58 PST
Investigating
We are currently investigating the issue of the tasks not starting for West customers
Posted Dec 06, 2021 - 05:50 PST
This incident affected: PowerSchool eSchoolPlus SIS.