PowerSchool Network Issues Impacting SSO Access
Incident Report for PowerSchool Products
Resolved
This incident has been resolved.
Posted Feb 03, 2023 - 14:08 PST
Monitoring
PowerSchool teams have applied a potential fix, resolving Google SSO access issues in the SIS.
Posted Jan 31, 2023 - 09:47 PST
Investigating
PowerSchool teams have identified an issue with the PowerSchool network impacting SSO access when logging into PowerSchool SIS, Enrollment, and Special Programs. This is affecting customers in the East and Central parts of the US.
Posted Jan 31, 2023 - 07:03 PST
This incident affected: Enrollment, PowerSchool SIS, and Unified Classroom Special Programs.