PowerSchool Learning - Login Issues
Incident Report for PowerSchool Products
Resolved
This incident has been resolved.
Posted May 22, 2020 - 10:14 PDT
Update
We worked diligently and full functionality was restored to PowerSchool Learning and Unified Classroom Class Pages. We apologize for any inconvenience this may have caused and appreciate your patience while we worked to resolve these issues. We strive to provide the best possible experience to our customers. Please don’t hesitate to contact PowerSchool Support with any questions.
Posted May 22, 2020 - 10:14 PDT
Monitoring
We have applied a fix and are currently monitoring the situation. We will provide updates as they become available.
Posted May 22, 2020 - 08:00 PDT
Identified
We have identified the issue and are working on implementing a fix. We apologize for the inconvenience this may have caused and we are working diligently to restore full system functionality. We will provide updates as they become available.
Posted May 22, 2020 - 07:46 PDT
Investigating
We are aware that some customers using PowerSchool Learning may currently be experiencing an issue when attempting to login. We apologize for the inconvenience this may have caused and we are working diligently to restore full system functionality. We will provide updates as they become available.
Posted May 22, 2020 - 06:53 PDT