Ecollect/Enrollment Express Cloud Portal Outage
Incident Report for PowerSchool Products
Resolved
This incident has been resolved.
Posted Jul 27, 2022 - 13:11 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 27, 2022 - 09:42 PDT
Investigating
We are currently investigating this issue.
Posted Jul 27, 2022 - 09:36 PDT
This incident affected: Enrollment Express/ECollect.