Powerschool Learning - Unable to submit assignments
Incident Report for PowerSchool Products
Resolved
This incident has been resolved. We thank you for patience while we worked to resolve this issue.
Posted Dec 10, 2020 - 06:26 PST
Update
We have scheduled the release to fix this issue for tonight. The maintenance window will be from 6:00 PM - 9:00 PM PST. We apologize for any inconvenience this may have caused and appreciate your patience while we work to resolve this issue.
Posted Dec 09, 2020 - 11:57 PST
Update
An unexpected issue prevented the escalation release from going out last night. We are investigating the problem and will update with a new release time as soon as possible. We apologize for any inconvenience this may have caused and appreciate your patience while we worked to resolve these issues.
Posted Dec 09, 2020 - 07:49 PST
Update
We are currently testing a resolution for this issue and are hopeful that we will be able to apply a permanent fix tonight. We apologize for any inconvenience this may have caused and appreciate your patience while we worked to resolve these issues.
Posted Dec 08, 2020 - 07:02 PST
Update
We have determine the root cause of the issue and our team is working diligently to restore functionality to PowerSchool Learning. We apologize for any inconvenience this may have caused and appreciate your patience while we worked to resolve these issues.
Posted Dec 07, 2020 - 10:25 PST
Identified
We have identified an issue where users are unable to submit assginments using Google Drive. We are currently investigating this issue and will update this page accordingly.
Posted Dec 07, 2020 - 06:26 PST