PowerSchool SIS - Intermittent connectivity issue for users from East zone.

Incident Report for PowerSchool Products

Resolved

The issue reported as intermittent connectivity affecting PowerSchool SIS customers only located in the East Zone has been resolved and this incident has been closed. (edited)
Posted Aug 04, 2025 - 07:35 PDT

Update

We are continuing to monitor for any further issues.
Posted Aug 01, 2025 - 13:53 PDT

Monitoring

We’ve implemented mitigation steps to address the intermittent connectivity issue impacting PowerSchool SIS customers in the East Zone. System performance has improved, and we are closely monitoring to ensure continued stability while we work toward a full resolution.
Posted Aug 01, 2025 - 13:52 PDT

Investigating

We are currently investigating an intermittent connectivity issue affecting PowerSchool SIS customers only located in the East Zone. Our engineering teams are actively working to identify the root cause and mitigate the impact as quickly as possible
Posted Aug 01, 2025 - 11:42 PDT
This incident affected: PowerSchool SIS.