PowerPack - The Flex Mailer outage is currently impacting non-Canadian customers.

Incident Report for PowerSchool Products

Resolved

The issue reported for Flex Mailer outage affecting non-Canadian customers has been resolved and this incident has been closed.
Posted May 16, 2025 - 12:34 PDT

Monitoring

Flex Mailer has been restored for the non-Canadian customers who were impacted by the outage this morning. Customers will be required to update to the 25.4.1 version of the Flex Mailer plugin in order to successfully send Flex Mailer emails.
The Canadian version of the Flex Mailer plugin is to be released this afternoon.
Posted May 16, 2025 - 11:51 PDT

Investigating

We are currently investigating reports of a Flex Mailer outage affecting non-Canadian customers. This outage is preventing the successful sending of Flex Mailer emails from SIS. We expect this issue to be temporary and are working diligently to resolve it. Regular updates will be provided as we make progress towards a resolution.
Posted May 16, 2025 - 07:51 PDT
This incident affected: PowerPack (Flex Mailer).