Performance Matters

Incident Report for PowerSchool Products

Resolved

We are pleased to report that the platform is fully restored and is now operational. Thank you to our valued customers for your patience and understanding.
Posted Mar 19, 2025 - 03:53 PDT

Identified

We apologize for the issue that has been impacting the Performance Matters platform today. We have been working as quickly as possible to address it and have been focused on bringing it back into service with priority. We are currently restoring the platform in a phased approach, and expect that it will be fully operational by tomorrow morning. We will continue to keep you informed, as appropriate.
Posted Mar 18, 2025 - 10:29 PDT

Investigating

We are aware of an issue that is impacting customers from accessing the Performance Matters platform. Our teams are currently working with priority to address the issue.
Posted Mar 17, 2025 - 22:55 PDT
This incident affected: Performance Matters.