Analytics & Insights: ETL are still in progress post v25.10.0.1 upgrade this weekend.

Incident Report for PowerSchool Products

Resolved

The issue has been fully resolved. All ETL jobs have successfully completed, and your dashboards now display the latest data. Thank you for your patience while we worked to restore normal service.
Posted Dec 09, 2025 - 07:28 PST

Update

Several ETL jobs within Analytics & Insights have successfully completed. However, we are continuing to investigate the causes of certain job failures and the extended processing times. Our team is actively working to determine the root cause and implement a full resolution. We will share further updates as additional information becomes available.

For more details please check the PS community article: https://help.powerschool.com/t5/Student-Analytics-Release/Known-Issue-Intermittent-ETL-Build-Issues-for-some-customers/ta-p/562741
Posted Dec 08, 2025 - 10:46 PST

Investigating

We have identified that several ETL jobs within Analytics & Insights are still in progress. We expect these jobs to complete shortly. We are monitoring the ETL runs and will continue to provide regular updates as we progress towards completion.
Posted Dec 08, 2025 - 07:17 PST
This incident affected: Analytics & Insights.