Unified Talent - Applicant Tracking Site Slowness

Incident Report for PowerSchool Products

Resolved

The issue reported for Applicant Tracking Site Slowness has been resolved and this incident has been closed.
Posted May 27, 2025 - 11:13 PDT

Monitoring

We have deployed a fix to production to address the latency issue within Applicant Tracking. we will continue to monitor the application availability to ensure consistent performance and critical functionality remains intact as expected.
Posted May 27, 2025 - 10:46 PDT

Identified

We have received reports of latency within Applicant Tracking. Teams have investigated the issue, and we are working on deploying a fix to production. We will continue to provide regular updates on our progress.
Posted May 27, 2025 - 09:07 PDT
This incident affected: Unified Talent (Applicant Tracking).