Analytics and Insights is currently being impacted by the Microsoft Global Outage.
Incident Report for PowerSchool Products
Resolved
We are pleased to inform you that the systems have been fully restored and are now back to normal operations. All services are operating as expected.

We apologize for any inconvenience this may have caused and thank you for your patience and understanding during this time. If you experience any further issues, please do not hesitate to contact our support team
Posted Jul 22, 2024 - 08:27 PDT
Monitoring
All customers should be able to access Unified Insights application.

A fix has been implemented to identified issue and we are monitoring the performance for any other issue.
Posted Jul 20, 2024 - 09:47 PDT
Identified
We are aware of a service interruption with Analytics & Insights. We are working to assess the situation and will provide you with regular updates as they become available. We appreciate your patience while we work to resolve this issue.
Posted Jul 19, 2024 - 08:14 PDT
This incident affected: Unified Insights.