Performance Matters - Baseball Card / Scoreboard Error
Incident Report for PowerSchool Products
Resolved
The issue with Baseball Card and Scoreboard errors has been resolved and users should no longer experience errors when accessing those reports. We apologize for the inconvenience this caused in accessing the reports.
Posted Jun 02, 2023 - 05:16 PDT
Investigating
We are currently investigating an issue with Baseball Card and Scoreboard populating an error and not populating students and data as expected. We will continue to update until this issue is resolved and student data can be accessed.
Posted Jun 02, 2023 - 04:34 PDT
This incident affected: Performance Matters.