BusinessPlus is being impacted by the Microsoft Global Outage.
Incident Report for PowerSchool Products
Resolved
This issue has been resolved for BusinessPlus.
Posted Jul 22, 2024 - 10:01 PDT
Monitoring
All BusinessPlus customers should now have access to the affected systems. We will continue to monitor the situation and provide additional updates, if needed.
Posted Jul 19, 2024 - 08:52 PDT
Investigating
The root cause of the issue was a Windows CrowdStrike update. We will continue to provide updates until the issue has been fully resolved.
Posted Jul 19, 2024 - 07:09 PDT
This incident affected: BusinessPlus.