Talk Desk calls and chat is down.

Incident Report for PowerSchool Products

Resolved

The Talkdesk vendor has implemented mitigation steps, and support engineers have confirmed successful login and functionality for chat and calls. Performance remains stable, and the incident is now resolved.
Posted Jul 10, 2025 - 12:59 PDT

Monitoring

The Talkdesk vendor has implemented mitigation steps to address the issue. Following these actions, support engineers have confirmed that they are now able to log in to the application and successfully initiate both chat and call functionalities.
We are currently monitoring the platform for continued stability and performance.
Posted Jul 09, 2025 - 15:39 PDT

Investigating

We are currently experiencing an issue where multiple support engineers are unable to log in to the Talkdesk application for both calls and chats. Upon investigation, we have confirmed that this is a nationwide issue acknowledged by the Talkdesk vendor.
We are closely monitoring the situation and will provide updates as more information becomes available.
Posted Jul 09, 2025 - 15:28 PDT
This incident affected: Support Tools (Chat, Phone Support).