Unified Classroom - Dashboard - Extreme Slowness Being Experienced By Users
Incident Report for PowerSchool Products
Resolved
Unified Classroom experienced extreme slowness which caused Degraded Performance that prevented users from navigating through Unified Classroom efficiently. Performance was restored today at 12:28 PM PST. We apologize for any inconvenience this may have caused and appreciate your patience while we worked to resolve these issues. We strive to provide the best possible experience to our customers. Please don’t hesitate to contact PowerSchool Support with any questions.
Posted Nov 04, 2019 - 12:35 PST
Investigating
We are currently investigating extreme slowness that some users are experiencing when trying to navigate the Dashboard area. This sometimes results in an error. We apologize for any inconvenience. Thank you for your patience.
Posted Nov 04, 2019 - 11:44 PST
This incident affected: Unified Classroom.