We have successfully resolved this issue at this time. We strive to provide the best possible experience for our customers. We want to thank you again for your patience as we worked to resolve this.
Posted Aug 29, 2023 - 10:35 PDT
Monitoring
At this time, we have resolved this issue. While we continue to monitor this issue, please reach out to PowerSchool Support via chat through our PowerSchool Community if you continue to experience any issues.
Posted Aug 29, 2023 - 08:32 PDT
Investigating
We are aware of a degraded performance with PowerSchool SIS. We are working to assess the situation and will provide you with regular updates as they become available. We appreciate your patience while we work to resolve this issue.
Posted Aug 29, 2023 - 06:34 PDT
Monitoring
At this time, we have resolved this issue. While we continue to monitor this issue, please reach out to PowerSchool Support via phone, web, or chat through our PowerSchool Community if you continue to experience any issues.
Posted Aug 28, 2023 - 17:52 PDT
Update
At this time, we are continuing to work to resolve this issue. We have scheduled emergency system maintenance for this evening from 8pm until 9pm (EST). A subset of customer sites will be unavailable during the majority of the window listed above. A technote has been sent to those directly impacted. Please continue to check this status page for ongoing updates. Updates will be published here and we will continue to monitor the performance of our systems closely over the upcoming week.
Posted Aug 28, 2023 - 13:32 PDT
Identified
We have been able to establish a workaround for this issue. Please log out, clear your cache and try logging in again. We are working to resolve this issue entirely and will continue posting ongoing updates to this status page.
Posted Aug 28, 2023 - 11:24 PDT
Monitoring
At this time, we have resolved this issue. While we continue to monitor this issue, please reach out to PowerSchool Support via phone, web, or chat through our PowerSchool Community if you continue to experience any issues.
Posted Aug 28, 2023 - 09:41 PDT
Identified
We have been able to establish a workaround for this issue. Please log out, clear your cache and try logging in again. We are working to resolve this issue entirely and will continue posting ongoing updates to this status page.
Posted Aug 28, 2023 - 09:08 PDT
Investigating
We are aware of a degraded performance with PowerSchool SIS. We are working to assess the situation and will provide you with regular updates as they become available. We appreciate your patience while we work to resolve this issue.