Multiple Products - Users are encountering issues accessing Enrollment, PowerSchool eSchoolPlus SIS, eFinancePlus, EnrollmentExpress/Ecollect, PowerSchool SIS, Special Programs.

Incident Report for PowerSchool Products

Resolved

This incident has been resolved.
Posted May 28, 2026 - 12:45 PDT

Update

We are continuing to monitor for any further issues.
Posted May 28, 2026 - 11:27 PDT

Monitoring

We are seeing improved performance and are monitoring for continued stability.
Posted May 28, 2026 - 11:13 PDT

Investigating

Multiple Products - Users are encountering issues accessing Enrollment, PowerSchool eSchoolPlus SIS, eFinancePlus, EnrollmentExpress/Ecollect, PowerSchool SIS, Special Programs.
Posted May 28, 2026 - 11:00 PDT
This incident affected: eFinancePlus, Enrollment, Enrollment Express/ECollect, PowerSchool eSchoolPlus SIS, PowerSchool SIS, and Special Programs.