Powerschool SIS - Google Address Validation Error

Incident Report for PowerSchool Products

Resolved

The fix applied yesterday has resolved this issue globally.
Posted Mar 10, 2023 - 07:56 PST

Monitoring

Powerschool has deployed a fix and we are monitoring results
Posted Mar 09, 2023 - 13:05 PST

Update

We are continuing to investigate this issue.
Posted Mar 09, 2023 - 13:00 PST

Investigating

PowerSchool is aware that there may be errors occurring when districts attempt to utilize the address validation function within the SIS. An error is being returned, and the validation screens are coming up blank.

We are working to determine the cause and correct the issue.
Posted Mar 09, 2023 - 12:22 PST
This incident affected: PowerSchool SIS.