PowerSchool Enrollment Express & Ecollect Forms
Incident Report for PowerSchool Products
Resolved
This incident has been resolved.
Posted May 17, 2021 - 17:18 PDT
Monitoring
The previously reported issues, that some users may have experienced, has since stabilized and we are seeing normal operation of the system. We will continue to monitor the situation to ensure that normal functionality continues.
Posted Apr 30, 2021 - 15:24 PDT
Identified
PowerSchool has identified an issue that may cause a service disruption for those using PowerSchool Enrollment Express and / or Ecollect Forms. We apologize for the inconvenience this may have caused and we are working diligently to restore full system functionality. We will provide updates as they become available.
Posted Apr 30, 2021 - 14:46 PDT
This incident affected: Enrollment Express/ECollect.