Atrieve - BC03 - Application issues impacting performance

Incident Report for PowerSchool Products

Resolved

This incident has been resolved.
Posted Mar 14, 2025 - 12:11 PDT

Monitoring

This incident has been resolved. PowerSchool has verified that Atrieve is operational again.

We apologize for the disruption.
Posted Mar 14, 2025 - 11:59 PDT

Identified

We are currently working on a fix for the issue impacting application functionality within Atrieve. As part of this process, users may experience a very brief interruption in service. We are making every effort to resolve the issue as quickly as possible and will keep you updated on our progress.

Thank you for your patience and understanding.
Posted Mar 14, 2025 - 11:06 PDT

Investigating

We are currently investigating an issue impacting the performance of Atrieve causing errors in some applications. Our team is currently working to resolve the issue.
Posted Mar 14, 2025 - 10:37 PDT
This incident affected: Atrieve (HOST03).