Schoology Learning
Incident Report for PowerSchool Products
Resolved
Our team has implemented a fix to resolve loading issues when accessing Schoology loading. The site is operating normally but may require a refresh in your web browser. The team will continue to monitor the results of the fix and site performance. Thank you for your patience.
Posted Oct 09, 2021 - 11:29 PDT
Investigating
Some users are experiencing degraded service while using Schoology Learning. We are investigating and will provide further updates.
Posted Oct 09, 2021 - 11:02 PDT
This incident affected: Schoology.