Curriculum & Instruction - Chalk app is down.

Incident Report for PowerSchool Products

Resolved

The issue affecting Curriculum & Instructions has been resolved. All services are functional now, and this incident has been closed.
Posted Nov 18, 2025 - 12:14 PST

Monitoring

A fix has been deployed by our Vendors to address the report where Curriculum & Instructions is currently experiencing issues with chalk app. We are currently monitoring the service to ensure stability and confirm that the issue has been fully resolved.
Posted Nov 18, 2025 - 08:30 PST

Identified

The cause of the issue within Curriculum & instructions has been identified. We are actively coordinating with our Vendor to implement a resolution. We will continue to share updates as they become available.
Posted Nov 18, 2025 - 04:43 PST

Investigating

We are investigating the report where Curriculum & Instructions is currently experiencing issues with chalk app. We are actively investigating the issue and coordinating with our third-party vendor to mitigate the impact. We will continue to provide regular updates as we progress towards a resolution.
Posted Nov 18, 2025 - 04:40 PST
This incident affected: Curriculum & Instruction.