PowerSchool SIS - Several users reporting application outage

Incident Report for PowerSchool Products

Resolved

The issue reported for PowerSchool SIS has been resolved and this incident has been closed
Posted Jan 06, 2026 - 09:42 PST

Monitoring

A fix has been deployed to address the application outage issue within PowerSchool. We are currently monitoring the service to ensure stability and confirm that the issue has been fully resolved.
Posted Jan 06, 2026 - 07:28 PST

Investigating

We are investigating the reports from few users that PowerSchool SIS is down. We are actively investigating the issue to mitigate the impact. We will continue to provide regular updates as we progress towards a resolution.
Posted Jan 06, 2026 - 07:08 PST
This incident affected: PowerSchool SIS.