PowerSchool Community - Inability to view case details

Incident Report for PowerSchool Products

Resolved

The issue reported for PowerSchool Community has been resolved and this incident has been closed
Posted Oct 13, 2025 - 12:30 PDT

Monitoring

We have deployed a fix that has resolved the issue in PowerSchool Community. We will continue to monitor the application to ensure consistent performance and critical functionality remains intact as expected.
Posted Oct 13, 2025 - 10:38 PDT

Investigating

We are investigating reports of users being unable to view the case details within PowerSchool Community. We are working diligently to mitigate the issue being reported and will continue to provide regular updates as we progress towards a resolution.
Posted Oct 13, 2025 - 09:35 PDT
This incident affected: Support Tools (PowerSchool Community).