Atrieve - BC03 - Application unavailable for customers on BC03
Incident Report for PowerSchool Products
Resolved
This incident has been resolved.
Posted Jan 30, 2025 - 07:21 PST
Monitoring
A fix has been implemented and we will continue to monitor results through the day.
Posted Jan 28, 2025 - 15:29 PST
Investigating
We are currently investigating an issue impacting access to Atrieve for customers on BC03. We will provide updates on our progress towards resolution.
Posted Jan 28, 2025 - 15:23 PST
This incident affected: Atrieve (HOST03).