This incident is now resolved. While we continue to monitor this issue, please reach out to PowerSchool Support via phone, web, or chat through our PowerSchool Community if you continue to experience any issues.
Posted Mar 11, 2025 - 13:08 PDT
Update
We are currently investigating an issue impacting the delivery of certain types broadcasts. Our team is actively working to resolve the matter.
Identified: Our teams have identified the underlying issue affecting some Email, Stationary, and Newsletter broadcasts in Canada. We have taken corrective steps, and will provide more information once the issue has been resolved.
Posted Mar 11, 2025 - 06:48 PDT
Identified
We are currently investigating an issue impacting the delivery of certain types broadcasts. Our team is actively working to resolve the matter.
Identified: Our teams have identified the underlying issue affecting some Email, Stationary, and Newsletter broadcasts in Canada. We have taken corrective steps, and the resolution process is expected to take up to 12 hours, starting from approximately 3:30 PM CST.
Posted Mar 10, 2025 - 14:54 PDT
This incident affected: SchoolMessenger (SchoolMessenger Communicate).