Naviance - Unable to access the Application using SSO

Incident Report for PowerSchool Products

Resolved

The issue reported for Naviance has been resolved and this incident has been closed. (edited)
Posted Aug 21, 2025 - 13:48 PDT

Monitoring

We have restored the services for Naviance and We will continue to monitor the application availability to ensure consistent performance and critical functionality remains intact as expected.
Posted Aug 21, 2025 - 12:32 PDT

Identified

We have identified the cause for the ongoing issue within Naviance and working on restoring the service. We will continue to provide regular updates on our progress.
Posted Aug 21, 2025 - 11:50 PDT

Investigating

We are investigating the reports of Users unable to login Naviance application using SSO. We are working diligently to mitigate the issue being reported and will continue to provide regular updates as we progress towards a resolution.
Posted Aug 21, 2025 - 11:10 PDT
This incident affected: Naviance.