Attendance Intervention Suite - Issues Sending Messages

Incident Report for PowerSchool Products

Resolved

The issue reported for sending messages within Attendance Intervention Suite has been resolved and this incident has been closed
Posted Sep 25, 2025 - 15:27 PDT

Identified

We have identified the cause for the ongoing issue sending messages within Attendance Intervention Suite and are working towards a resolution. We will continue to provide regular updates on our progress.
Posted Sep 25, 2025 - 07:15 PDT

Investigating

We are investigating reports of issues sending messages within Attendance Intervention Suite. We are working diligently to mitigate the issue being reported and will continue to provide regular updates as we progress towards a resolution..
Posted Sep 24, 2025 - 08:21 PDT
This incident affected: Attendance Intervention Suite.