SchoolMessenger Communicate - Login Failures for US & CA

Incident Report for PowerSchool Products

Resolved

The issue reported for SchoolMessenger has been resolved and this incident has been closed.
Posted Aug 22, 2025 - 07:51 PDT

Monitoring

We have deployed a fix to the production that has resolved the issue for Login failure for US & CA within SchoolMessenger Communicate. We will continue to monitor the application to ensure the consistent performance and critical functionality remains intact as expected.
Posted Aug 21, 2025 - 23:06 PDT

Identified

We have identified a resolution for the ongoing issue in SchoolMessenger and we are working on deploying a fix to production. We will continue to provide regular updates on our progress.
Posted Aug 21, 2025 - 21:13 PDT

Investigating

We are investigating the reports of Login failure for US & CA within SchoolMessenger Communicate. We are working diligently to mitigate the issue being reported and will continue to provide regular updates as we progress towards a resolution.
Posted Aug 21, 2025 - 17:42 PDT
This incident affected: SchoolMessenger (SchoolMessenger Communicate).