PS Community - Users cannot see case details in the manage case view

Incident Report for PowerSchool Products

Resolved

The issue reported for Users are unable to see the case details in the Manage case view within PowerSchool Community has been resolved and this incident has been closed.
Posted Aug 07, 2025 - 12:32 PDT

Investigating

We are investigating the reports of Users unable to see the case details in the Manage case view within PowerSchool Community. We are working diligently to mitigate the issue being reported and will continue to provide regular updates as we progress towards a resolution.
Posted Aug 07, 2025 - 09:51 PDT
This incident affected: Support Tools (PowerSchool Community).