PowerSchool SIS - Hosting Interruption
Incident Report for PowerSchool Products
Resolved
This incident has been resolved.
Posted May 02, 2022 - 14:19 PDT
Monitoring
At this time, Powerschool SIS clients appear to be back online without issue. While we continue to monitor this issue and investigate the cause please reach out to PowerSchool Support via phone, web, or chat through our PowerSchool Community if you continue to experience any issues.
Posted Apr 26, 2022 - 07:28 PDT
Investigating
We are aware of a service interruption with Powerschool SIS. We are working to assess the situation and will provide you with regular updates as they become available. We appreciate your patience while we work to resolve this issue.
Posted Apr 26, 2022 - 07:09 PDT
This incident affected: PowerSchool SIS.