CMP / Ecollect Forms - 504 Gateway Timeout in Parent Portal

Incident Report for PowerSchool Products

Resolved

The issue reported for Ecollect Forms within the Parent Portal has been resolved and this incident has been closed.
Posted Aug 04, 2026 - 01:52 PDT

Monitoring

We have successfully deployed a fix to the production environment. Initial results indicate that the service is functioning normally and remains stable. We are continuing to closely monitor performance to ensure continued reliability.
Posted Aug 03, 2026 - 15:02 PDT

Update

We continue to investigate the issue affecting Ecollect Forms within the Parent Portal. We understand this is impacting critical workflows and apologize for the disruption.

We will continue to provide updates as this investigation progresses. Thank you for your patience.
Posted Aug 03, 2026 - 13:01 PDT

Investigating

We are currently investigating an issue affecting Ecollect Forms within the Parent Portal. Some users are experiencing 504 Gateway Timeout errors when attempting to access or submit forms. We understand this is impacting critical workflows and apologize for the disruption.

We will continue to provide updates as this investigation progresses. Thank you for your patience.
Posted Aug 03, 2026 - 10:58 PDT
This incident affected: Enrollment Express/ECollect.