The issue reported for multiple PowerSchool products has been resolved and this incident has been closed
Posted Feb 18, 2026 - 00:48 PST
Monitoring
We have deployed a production fix that has resolved the issue across all impacted PowerSchool products. We will continue to monitor the applications to ensure stable performance and to confirm that all critical functionality remains operating as expected.
Posted Feb 17, 2026 - 10:36 PST
Update
We are continuing to deploy the fix incrementally, and the majority of products have been fully restored.
Posted Feb 17, 2026 - 09:59 PST
Update
We are continuing to work on a fix for this issue.
Posted Feb 17, 2026 - 08:33 PST
Update
We are continuing to deploy the fix incrementally, and the majority of products have been fully restored.
Posted Feb 17, 2026 - 08:24 PST
Update
We are continuing to work on a fix for this issue.
Posted Feb 17, 2026 - 05:12 PST
Identified
We have identified the cause for the ongoing issue in multiple PowerSchool products and are working on deploying a fix to production. We will continue to provide regular updates on our progress.
Posted Feb 17, 2026 - 04:44 PST
Investigating
We are investigating reports of icons not working/grayed out across multiple PowerSchool products. We are working diligently to mitigate the reported issue and will continue to provide regular updates as we progress toward a resolution.