Digital Document Delivery - SSO School Users Cannot Create and Send Jobs
Incident Report for PowerSchool Products
Resolved
The issue is now resolved.

Users who logged in during this time were affected and their roles were edited. Users who use SSO need to log out and log back in to have their access restored. Users who do not use SSO may need to be manually reverted. That will be completed by PowerSchool, and is in progress now.
Posted Feb 06, 2025 - 11:37 PST
Identified
We are currently investigating the issue and have identified a fix. There is a planned release to resolve the issue. Until then, users accessing the Document Management platform using SSO are unable to send jobs. If users are able to use direct login, they can use that as a temporary workaround.
Posted Feb 06, 2025 - 10:08 PST
This incident affected: Document Cloud (US & Canada) (Document Delivery US, Document Management US, Document Delivery Canada, Document Management Canada).