Atrieve Performance - End users are experiencing degradation when using Atrieve Web, the Atrieve Portal, Document Storage and Scanning
Incident Report for PowerSchool Products
Resolved
This incident has been resolved.
Posted Jan 24, 2025 - 09:22 PST
Monitoring
We are pleased to inform you that the infrastructure issue causing performance degradation since January 6th has been addressed. Our systems are now operating at expected performance levels.

We will continue to monitor as our team is actively working on further optimizations to prevent future occurrences. We will share more details about the root cause as soon as they become available.

Thank you for your continued patience and partnership. We remain committed to improving our products and services to better serve you.
Posted Jan 15, 2025 - 15:14 PST
Update
After addressing the data balancing issue last week, we uncovered a new infrastructure issue that is currently under investigation.

Following the server restart on January 9th, we observed performance improvements. However, we are aware of ongoing performance slowdowns that users will still experience, while our team actively works to address the root cause.

These efforts will take additional time to resolve through this week, so we advise end users to plan accordingly to allow time for business-critical tasks, such as payroll, to be completed.

We apologize for any inconvenience and appreciate your patience and support as we work towards a comprehensive resolution. Rest assured, we are committed to resolving this with the highest priority.
Posted Jan 14, 2025 - 11:12 PST
Update
We have taken significant steps to balance data and halt backend processes to stabilize performance across the Atrieve platform. While we have seen improvements and successful tests, some customers may still experience intermittent issues with Atrieve Web, the Atrieve Portal, Document Storage, and Scanning.

To further enhance stability, our team will perform a server restart after business hours tonight.

We appreciate your patience and understanding as we work to resolve these issues. Thank you for your continued support.
Posted Jan 09, 2025 - 13:40 PST
Update
We have identified an issue that began on January 6th, leading to degraded performance within Atrieve. Our team has isolated the problem and is actively working on a resolution. We understand the impact this has on your experience and are committed to resolving the issue as quickly as possible.

Once the performance issue has been fully resolved and validated, we will share more details on the root cause. Thank you for your patience and understanding.
Posted Jan 08, 2025 - 15:36 PST
Identified
We continue to troubleshoot an issue that is impacting the performance of Atrieve. Yesterday we identified a source of the problem and are working through an action plan to address it. At this time, we do not have a confirmed timeline to resolution, however, as soon as we do, we will provide more information.
Posted Jan 08, 2025 - 09:56 PST
Update
We have confirmed that the impact of the problem includes other areas of functionality, including AtrieveWeb, the Atrieve Portal, Document Storage, and Scanning, and other areas.

Our team continues to work in a war room effort to resolve this problem.
Posted Jan 07, 2025 - 11:27 PST
Investigating
We have received feedback of continued slow responsiveness when using Atrieve this morning. Our teams are actively investigating the root cause to determine a resolution to this problem.
Posted Jan 07, 2025 - 08:12 PST
Monitoring
A fix has been implemented and we will monitor the results through this evening and normal business operations on Tuesday.
Posted Jan 06, 2025 - 16:26 PST
Update
Our team is actively working on this issue. We do not yet have a timeline for resolution but we will provide an update when we do.
Posted Jan 06, 2025 - 15:03 PST
Investigating
We have received reports and have verified that users of AtrieveWeb are experiencing degradation and delays when working in the application. Our teams are currently investigating this incident.
Posted Jan 06, 2025 - 11:47 PST
This incident affected: Atrieve (HOST02, HOST03, HOST04, HOST05, HOST06, HOST07, HOST08, HOST11, HOST12, HOST31, HOST32, HOST33, HOST34, HOST35, HOST36).