Digital Document Delivery - SSO School Users Cannot Create and Send Jobs
Incident Report for PowerSchool Products
Resolved
This incident has been resolved.
Posted Jan 29, 2025 - 08:43 PST
Identified
We are currently investigating the issue and have identified a fix. There is a planned release to resolve the issue. Until then, school users accessing the Document Management platform using SSO are unable to send jobs. Administrator users are not affected by this issue, and are able to create and send jobs.
Posted Jan 28, 2025 - 10:10 PST
This incident affected: Document Cloud (US & Canada) (Document Delivery US, Document Signature Canada).